#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)PATTERN BEGINS HERE.*?\);"
Local $sString = "... This is preceding text" & @CRLF & _
"PATTERN BEGINS HERE (" & @CRLF & _
"pattern can continue for any number of lines..." & @CRLF & _
");" & @CRLF & _
"this is trailing text that is not part of the pattern"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")