re = /(?s)PATTERN BEGINS HERE.*?\);/
str = '... This is preceding text
PATTERN BEGINS HERE (
pattern can continue for any number of lines...
);
this is trailing text that is not part of the pattern'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end