package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)PATTERN BEGINS HERE.*?\);`)
var str = `... This is preceding text
PATTERN BEGINS HERE (
pattern can continue for any number of lines...
);
this is trailing text that is not part of the pattern`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}