import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)PATTERN BEGINS HERE.*?\\);";
final String string = "... This is preceding text\n"
+ "PATTERN BEGINS HERE (\n"
+ "pattern can continue for any number of lines...\n"
+ ");\n"
+ "this is trailing text that is not part of the pattern";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}