#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(0?[1-9]|1\d|2[0-8])[\/](0?[1-9]|1[0-2])|(29|30)[\/](0?[13-9]|1[0-2])|(31)[\/](0?[13578]|1[02]))[\/](0{2,3}[1-9]|0{1,2}[1-9]\d|0?[1-9]\d{2}|[1-9]\d{3})|(29)[\/](0?2)[\/](\d{1,2}(?:0[48]|[2468][048]|[13579][26])|(?:0?[48]|[13579][26]|[2468][048])00))$"
Local $sString = "19/6/2003" & @CRLF & _
"23/4/2003" & @CRLF & _
"25/12/2022" & @CRLF & _
"15/7/2026" & @CRLF & _
"30/2/2004" & @CRLF & _
"32/11/2005" & @CRLF & _
"0/5/2001"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")