package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:(0?[1-9]|1\d|2[0-8])[\/](0?[1-9]|1[0-2])|(29|30)[\/](0?[13-9]|1[0-2])|(31)[\/](0?[13578]|1[02]))[\/](0{2,3}[1-9]|0{1,2}[1-9]\d|0?[1-9]\d{2}|[1-9]\d{3})|(29)[\/](0?2)[\/](\d{1,2}(?:0[48]|[2468][048]|[13579][26])|(?:0?[48]|[13579][26]|[2468][048])00))$`)
var str = `19/6/2003
23/4/2003
25/12/2022
15/7/2026
30/2/2004
32/11/2005
0/5/2001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}