package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([A-Z]([0-9][-_])?)?SPRINT[0-9]+`)
var str = `A1-SPRINT1
SPRINT1
ASPRINT1243
R1_sprint3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}