re = /^([A-Z]([0-9][-_])?)?SPRINT[0-9]+/mi
str = 'A1-SPRINT1
SPRINT1
ASPRINT1243
R1_sprint3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end