// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([A-Z]([0-9][-_])?)?SPRINT[0-9]+").unwrap();
let string = "A1-SPRINT1
SPRINT1
ASPRINT1243
R1_sprint3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}