$re = '/^([A-Z]([0-9][-_])?)?SPRINT[0-9]+/mi';
$str = 'A1-SPRINT1
SPRINT1
ASPRINT1243
R1_sprint3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);