$re = '/(^([#]+|[*-+]\.|[0-9]+\.|[ ]{3,}|[> ]+)\s([^\n]+)$|([*_~\-]+)([^\4]+?)\4|(`+)([^\n]+)?\n([^\6]+?)\6)/m';
$str = '# 标题
引用
> 缩进
>> 多级缩进
> > 呵呵
普通文本 *加粗文本* ***特别粗的文本*** ~删除~ _斜体_
```JavaScript
Code
```
另一个代码段
```
Code
```
## 二级标题
1. 有序 列表一
2. 有序列表二
3. 有序列表三
*. 无序列表一
*. 无序列表二';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);