#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<edition>\d{1,8}-\d{1,8})?_?(?<name>[^_.]+)_?(?<artist>[^_.]+)?.(?<extension>[\S]{1,8})?$"
Local $sString = "2-13_oops-i-did-it-again_britney-spears.mp3" & @CRLF & _
"3-13_toxic_britney-spears.vaw" & @CRLF & _
"hold-it-against-me_britney-spears.flac" & @CRLF & _
"unknown.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")