re = /(?<edition>\d{1,8}-\d{1,8})?_?(?<name>[^_.]+)_?(?<artist>[^_.]+)?.(?<extension>[\S]{1,8})?$/m
str = '2-13_oops-i-did-it-again_britney-spears.mp3
3-13_toxic_britney-spears.vaw
hold-it-against-me_britney-spears.flac
unknown.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end