const regex = /(?<edition>\d{1,8}-\d{1,8})?_?(?<name>[^_.]+)_?(?<artist>[^_.]+)?.(?<extension>[\S]{1,8})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<edition>\\d{1,8}-\\d{1,8})?_?(?<name>[^_.]+)_?(?<artist>[^_.]+)?.(?<extension>[\\S]{1,8})?$', 'gm')
const str = `2-13_oops-i-did-it-again_britney-spears.mp3
3-13_toxic_britney-spears.vaw
hold-it-against-me_britney-spears.flac
unknown.mp3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}