import re
regex = re.compile(r"(?<edition>\d{1,8}-\d{1,8})?_?(?<name>[^_.]+)_?(?<artist>[^_.]+)?.(?<extension>[\S]{1,8})?$", flags=re.MULTILINE)
test_str = ("2-13_oops-i-did-it-again_britney-spears.mp3\n"
"3-13_toxic_britney-spears.vaw\n"
"hold-it-against-me_britney-spears.flac\n"
"unknown.mp3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")