#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+(?:[03-9]|\d{2,})$"
Local $sString = "# 111.111.111.111" & @CRLF & _
"112.112.112.112 1" & @CRLF & _
"113.113.113.113 2" & @CRLF & _
"114.114.114.114 3" & @CRLF & _
"115.115.115.115 4" & @CRLF & _
"115.115.115.115 445" & @CRLF & _
"115.115.115.115 123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")