use strict;
my $str = '# 111.111.111.111
112.112.112.112 1
113.113.113.113 2
114.114.114.114 3
115.115.115.115 4
115.115.115.115 445
115.115.115.115 123';
my $regex = qr/^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+(?:[03-9]|\d{2,})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}