$re = '/^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+(?:[03-9]|\d{2,})$/m';
$str = '# 111.111.111.111
112.112.112.112 1
113.113.113.113 2
114.114.114.114 3
115.115.115.115 4
115.115.115.115 445
115.115.115.115 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);