#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) (B{0,3}[^B]+)*B{0,3} | B{0,3}"
Local $sString = "sdBBdfsBBB" & @CRLF & _
"BfsBBBdsfBBB" & @CRLF & _
"fsBBBBsfBB" & @CRLF & _
"BBBBBfsBBBsd" & @CRLF & _
"BBBxBBByBBB" & @CRLF & _
"xBBBB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")