re = / (B{0,3}[^B]+)*B{0,3} | B{0,3}/m
str = 'sdBBdfsBBB
BfsBBBdsfBBB
fsBBBBsfBB
BBBBBfsBBBsd
BBBxBBByBBB
xBBBB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end