// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) (B{0,3}[^B]+)*B{0,3} | B{0,3}").unwrap();
let string = "sdBBdfsBBB
BfsBBBdsfBBB
fsBBBBsfBB
BBBBBfsBBBsd
BBBxBBByBBB
xBBBB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}