package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{(.+)\}$`)
var str = `{abc-def-qwe}
{anthing-else-that-you-wish}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}