$re = '/^\{(.+)\}$/m';
$str = '{abc-def-qwe}
{anthing-else-that-you-wish}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;