re = /^\{(.+)\}$/m
str = '{abc-def-qwe}
{anthing-else-that-you-wish}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result