#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^[A-Z]{3,}[0-9]{7,}$)(?=^[A-Z0-9]{10,14}$)"
Local $sString = "ROM1234567" & @CRLF & _
"ROMM1234567" & @CRLF & _
"ROM123456789" & @CRLF & _
"" & @CRLF & _
"input should not work: " & @CRLF & _
"RO1234567" & @CRLF & _
"RO123456" & @CRLF & _
"ROM123456" & @CRLF & _
"ROM123456789012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")