re = /(?=^[A-Z]{3,}[0-9]{7,}$)(?=^[A-Z0-9]{10,14}$)/m
str = 'ROM1234567
ROMM1234567
ROM123456789
input should not work:
RO1234567
RO123456
ROM123456
ROM123456789012'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end