using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^[A-Z]{3,}[0-9]{7,}$)(?=^[A-Z0-9]{10,14}$)";
string input = @"ROM1234567
ROMM1234567
ROM123456789
input should not work:
RO1234567
RO123456
ROM123456
ROM123456789012";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}