# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=^[A-Z]{3,}[0-9]{7,}$)(?=^[A-Z0-9]{10,14}$)"
test_str = ("ROM1234567\n"
"ROMM1234567\n"
"ROM123456789\n\n"
"input should not work: \n"
"RO1234567\n"
"RO123456\n"
"ROM123456\n"
"ROM123456789012")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.