import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[A-Za-z0-9!#$%&'*+\\-\\/=?^_`\\{|\\}~]|(?<=^|\\.)\"|\"(?=$|\\.|@)|(?<=\".*)[ .](?=.*\")|(?<!\\.)\\.){1,64})(@)((?:[A-Za-z0-9.\\-])*(?:[A-Za-z0-9])\\.(?:[A-Za-z0-9]){2,})$";
final String string = "Valid email addresses\n\n"
+ "simple@example.com\n\n"
+ "very.common@example.com\n\n"
+ "disposable.style.email.with+symbol@example.com\n\n"
+ "other.email-with-hyphen@example.com\n\n"
+ "fully-qualified-domain@example.com\n\n"
+ "user.name+tag+sorting@example.com\n"
+ "(may go to user.name@example.com inbox depending on mail server)\n\n"
+ "x@example.com\n"
+ "(one-letter local-part)\n\n"
+ "example-indeed@strange-example.com\n\n"
+ "example@s.example\n"
+ "(see the List of Internet top-level domains)\n\n"
+ "\" \"@example.org\n"
+ "(space between the quotes)\n\n"
+ "\"john..doe\"@example.org\n"
+ "(quoted double dot)\n\n"
+ "=============================================================\n"
+ "Invalid email addresses\n\n"
+ "Abc.example.com\n"
+ "(no @ character)\n\n"
+ "A@b@c@example.com\n"
+ "(only one @ is allowed outside quotation marks)\n\n"
+ "a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
+ "(none of the special characters in this local-part are allowed outside quotation marks)\n\n"
+ "just\"not\"right@example.com\n"
+ "(quoted strings must be dot separated or the only element making up the local-part)\n\n"
+ "this is\"not\\allowed@example.com\n"
+ "(spaces, quotes, and backslashes may only exist when within quoted strings and preceded by a backslash)\n\n"
+ "this\\ still\\\"not\\\\allowed@example.com\n"
+ "(even if escaped (preceded by a backslash), spaces, quotes, and backslashes must still be contained by quotes)\n\n"
+ "1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
+ "(local part is longer than 64 characters)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}