#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^bins\/fs:\/\/rrrr([bins/fs://\w*]+)?"
Local $sString = "bins/fs://rrrr - should match" & @CRLF & _
"" & @CRLF & _
"bins/fs://raw/gg - should match" & @CRLF & _
"" & @CRLF & _
"bins/fs://raw/gg/qq - should match" & @CRLF & _
"" & @CRLF & _
"bins/gs://raw/mm - should not match gs" & @CRLF & _
"" & @CRLF & _
"bins/gs - should not match" & @CRLF & _
"" & @CRLF & _
"library - should not match" & @CRLF & _
"" & @CRLF & _
"junk/fs:// - should not match" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")