re = /^bins\/fs:\/\/rrrr([bins\/fs:\/\/\w*]+)?/mi
str = 'bins/fs://rrrr - should match
bins/fs://raw/gg - should match
bins/fs://raw/gg/qq - should match
bins/gs://raw/mm - should not match gs
bins/gs - should not match
library - should not match
junk/fs:// - should not match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end