const regex = /^bins\/fs:\/\/rrrr([bins/fs://\w*]+)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^bins\\\/fs:\\\/\\\/rrrr([bins\/fs:\/\/\\w*]+)?', 'gmi')
const str = `bins/fs://rrrr - should match
bins/fs://raw/gg - should match
bins/fs://raw/gg/qq - should match
bins/gs://raw/mm - should not match gs
bins/gs - should not match
library - should not match
junk/fs:// - should not match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}