import re
regex = re.compile(r"^bins\/fs:\/\/rrrr([bins/fs://\w*]+)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("bins/fs://rrrr - should match\n\n"
"bins/fs://raw/gg - should match\n\n"
"bins/fs://raw/gg/qq - should match\n\n"
"bins/gs://raw/mm - should not match gs\n\n"
"bins/gs - should not match\n\n"
"library - should not match\n\n"
"junk/fs:// - should not match\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")