import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(deb|deb-src)\\s+(http:\\/\\/[^\\s]*debian[^\\s]*)\\s+(.+?)\\s+main\\s+contrib.*$\n";
final String string = "deb http://ftp.ru.debian.org/debian bullseye main contrib\n"
+ "deb-src http://ftp.ru.debian.org/debian bullseye main contrib\n\n"
+ "deb http://security.debian.org/debian-security bullseye-security main contrib\n"
+ "deb-src http://security.debian.org/debian-security bullseye-security main contrib\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}