$re = '/^(deb|deb-src)\s+(http:\/\/[^\s]*debian[^\s]*)\s+(.+?)\s+main\s+contrib.*$
/m';
$str = 'deb http://ftp.ru.debian.org/debian bullseye main contrib
deb-src http://ftp.ru.debian.org/debian bullseye main contrib
deb http://security.debian.org/debian-security bullseye-security main contrib
deb-src http://security.debian.org/debian-security bullseye-security main contrib
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);