const regex = new RegExp('^(deb|deb-src)\\s+(http:\\/\\/[^\\s]*debian[^\\s]*)\\s+(.+?)\\s+main\\s+contrib.*$
', 'gm')
const str = `deb http://ftp.ru.debian.org/debian bullseye main contrib
deb-src http://ftp.ru.debian.org/debian bullseye main contrib
deb http://security.debian.org/debian-security bullseye-security main contrib
deb-src http://security.debian.org/debian-security bullseye-security main contrib
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}