using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sa(\d+)";
string input = @"Target file 39: Assignment4/Assignment4-sa471 - Sarah Iwobi.pde";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}