package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sa(\d+)`)
var str = `Target file 39: Assignment4/Assignment4-sa471 - Sarah Iwobi.pde`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}