re = /sa(\d+)/m
str = 'Target file 39: Assignment4/Assignment4-sa471 - Sarah Iwobi.pde'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end