$re = '`sa(\d+)`m';
$str = 'Target file 39: Assignment4/Assignment4-sa471 - Sarah Iwobi.pde';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);