using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^%]+(?=%[^%]*%$)";
string input = @"%E:%test%dc1%dc.exe%
%E:%test%test2%dc2%dc.exe%
%E:%test%test2%test3%dc3%dc.exe%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}