re = /[^%]+(?=%[^%]*%$)/m
str = '%E:%test%dc1%dc.exe%
%E:%test%test2%dc2%dc.exe%
%E:%test%test2%test3%dc3%dc.exe%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end