import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^%]+(?=%[^%]*%$)";
final String string = "%E:%test%dc1%dc.exe%\n"
+ "%E:%test%test2%dc2%dc.exe%\n"
+ "%E:%test%test2%test3%dc3%dc.exe%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}