const regex = /[^%]+(?=%[^%]*%$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^%]+(?=%[^%]*%$)', 'gm')
const str = `%E:%test%dc1%dc.exe%
%E:%test%test2%dc2%dc.exe%
%E:%test%test2%test3%dc3%dc.exe%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}