use strict;
my $str = 'Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\2020db.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ccaldb.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput2.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput2.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ecaldb.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egcaldb.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eginput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput2.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput3.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\einput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eoutput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ercaldb.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Engine\\erinput.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\testing.dta
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\informet.dba
Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba
Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\informet.dba
Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba';
my $regex = qr/^.*((2020Model|Engine|TIMFCST).*\.dba|.*\.dta)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}