using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]\d+";
string input = @"Bill Number: S989610413
Bill Number: D187529186
Bill Number: E103948103
Bill Number: W1230134812
Bill Number: P698129481000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}