package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]\d+`)
var str = `Bill Number: S989610413
Bill Number: D187529186
Bill Number: E103948103
Bill Number: W1230134812
Bill Number: P698129481000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}