import re
regex = re.compile(r"[A-Z]\d+", flags=re.MULTILINE)
test_str = ("Bill Number: S989610413\n"
"Bill Number: D187529186\n"
"Bill Number: E103948103\n"
"Bill Number: W1230134812\n"
"Bill Number: P698129481000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")