// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]\d+").unwrap();
let string = "Bill Number: S989610413
Bill Number: D187529186
Bill Number: E103948103
Bill Number: W1230134812
Bill Number: P698129481000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}