#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-z]{1,4}\d{1,4}(?<=\b[a-z\d]{5})"
Local $sString = "a1111" & @CRLF & _
"aa111" & @CRLF & _
"aaa11b" & @CRLF & _
"aaaa1 x" & @CRLF & _
"a1a1a" & @CRLF & _
"aa11a" & @CRLF & _
"aa11" & @CRLF & _
"1aaaa x"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")